Back to overview
Downtime

Google Cloud outage affecting login and agreement creation

Jun 12 at 11:50am PDT
Affected services
Harbour App
Harbour API
Harbour Documents
Harbour Webhooks

Resolved
Jun 12 at 02:04pm PDT

Resolved

All Harbour services have been restored. Users can now log in and create agreement links normally. We'll continue monitoring for any residual issues.

Updated
Jun 12 at 01:54pm PDT

Monitoring

Google Cloud has implemented fixes and most regions have recovered. We're seeing partial restoration of Harbour services and are monitoring for full recovery.

Login functionality is beginning to return for some users. Agreement creation remains intermittent. We'll continue monitoring until all services are fully stable.

Next update within 1 hour or when fully resolved.

Updated
Jun 12 at 12:57pm PDT

Identified

We have confirmed the issue is related to a major Google Cloud Platform service disruption affecting multiple regions. Login and agreement link creation are impacted. Existing documents and agreements remain safe and accessible.

Updated
Jun 12 at 12:27pm PDT

Investigating

We are investigating reports of users unable to log into Harbour and create new agreement links. Initial investigation points to issues with our cloud infrastructure provider.

Created
Jun 12 at 11:50am PDT

Major outage

We've identified that a widespread Google Cloud Platform outage is preventing users from logging into Harbour and creating new agreement links. Existing agreements remain accessible via direct links.

We're monitoring Google's recovery efforts and will update when services are restored.